👉 Jos asennat laajennuksia, joita ei ole testattu WordPress-versiossasi?

Miten tehdä WordPress-blogi

Usein käyttäjät kysyvät meiltä varoituksen siitä, että laajennusta ei testata WordPress-versiona. Pitäisikö pluginat asentaa pluginiksi? tai löytää toisen plugin? Tässä artikkelissa keskustelemme siitä, miksi asennat laajennuksia, joita ei ole testattu WordPress-versiossasi? Mitä se tarkoittaa ja miten voit auttaa WordPress-yhteisöä?

Kun asennat laajennuksen WordPressin hallinta-alueelta, saatat nähdä varoituksen siitä, että laajennusta ei ole testattu WordPress-versiossasi.

Miten WordPress saa testattuja tietoja?

Virallinen WordPress-lisäosasto on suurin ja avoimen lähdekoodin WordPress-laajennuksen kokoelma. Lähettäessäsi plugin, kirjoittajat ovat velvollisia toimittamaan "readme" -tiedoston pluginsineen. Tämän readme-tiedoston avulla plugin-hakemisto käyttää plugin-sivua.

Readme-tiedosto sisältää "Testattu jopa" tunniste, jota käytetään tietojen näyttämiseen. Plugin-kirjoittajien odotetaan pitävän nämä tiedot ajan tasalla.

Tämä tarkoittaa, että jokaisen WordPress-julkaisun yhteydessä plugin kirjoittajien pitäisi testata niiden laajennukset ja päivittää readme-tiedostoja pluginsille.

Miksi Plugin-tekijät eivät päivitä tätä tietoa?

Monet plugin-kirjoittajat eivät päivitä readme-tiedostojasi lainkaan, vaikka he testivät pluginsa uusimman version kanssa.

Ihanteellisessa maailmassa haluamme kaikkien plugin-kirjoittajien päivittää nämä tiedot. Mutta emme elää ihanteellisessa maailmassa.

Muista, että nämä lisäosat ovat ilmaisia, etkä ole maksullisia kirjoittajia lataamaan niitä ja käyttämään niitä. Plugin-kirjoittajat tuntevat vähemmän haluavansa päivittää readme-tiedostoa jokaisella julkaisulla. He ovat yleensä kiireisiä kokopäiväisissä työpaikoissaan ja maksullisissa kehityshankkeissaan.

Videon opetusohjelma

Tilaa WPBeginner

Jos et pidä videota tai tarvitset lisätietoja, jatka lukemista.

Pitäisikö minun asentaa nämä laajennukset?

Kyllä sinun pitäisi. Vain siksi, että plugin-kirjoittaja ei päivittänyt readme-tiedostoaan ei tarkoita sitä, että he eivät ole testanneet pluginaan tai että plugin ei toimi WordPressin uusimman version kanssa.

Jos kuulit plugin WPBeginner, niin voit turvallisesti olettaa, että olemme testannut plugin uusin versio WordPress. Jos tarkastelemasi artikkeli julkaistiin melko äskettäin, tämä tarkoittaa, että plugin on yhteensopiva WordPressin uusimman version kanssa.

Toisaalta, jos laajennusta ei ole päivitetty yli kaksi vuotta, tämä tarkoittaa, että todennäköisesti plugin on hylätty. Tällöin asennusta ei saa asentaa.

Olisi mielenkiintoista huomata, että monet lisäosat, joita ei ole päivitetty yli kahden vuoden ajan, toimivat vielä hyvin. Asenna ne kuitenkin omalla vastuullasi.

Kuinka voit auttaa?

Voit asentaa plugin WordPress-sivustolle ja testata sen. Jos se toimii odotetulla tavalla, palaa sitten plugin -sivulle. Kirjaudu sisään WordPress.org-käyttäjätunnuksella ja salasanalla. Siirry sitten sivun alareunaan, josta näkyy yhteensopivuusosa.

Valitse vain WordPress-versio, laajennusversio ja napsauta sitten Works-painiketta. Näin tekemällä muut käyttäjät tietävät, että olet testannut laajennuksen ja se toimii kuten luvattiin.

Voit myös ottaa yhteyttä plugin-kirjoittajiin ja pyytää heitä päivittämään plugin-tiedostonsa

Mitä tehdä, kun laajennus on rikki?

Jälleen kerran haluaisimme muistuttaa käyttäjiltämme, että jos se on ilmainen laajennus, niin plugin-kirjoittaja on toimittanut sen itselleen. Ei ole takuuta, ei edes implisiittisen takuun takuu. Mutta kysymys on, miten voit auttaa yhteisöä käsittelemään rikki plugins?

Sen sijaan, että jätit tarkan kommentin plugin-tukilangasta, voit jättää rakentavan ja hyödyllisen palautteen. Katso oppaamme siitä, kuinka oikein pyydät WordPress-tukea ja hankkimaan sen.

Ennen kuin teet mitään, yritä asentaa plugin eri live-tai paikallinen WordPress asennus. Varmista, että pystyt toistamaan saman virheen myös muissa asennuksissa.

Kun olet varma, että plugin on rikki, yksinkertaisesti kuvaile tukivirheen virhe ja jätä se plugin-kirjoittajalle tai yhteisöön. Jos et saa vastausta, voit yrittää tavoittaa plugin-kirjoittajalle. Useimmissa laajennuksen tekijöissä on yhteystiedot WordPress.org-profiilisivuillaan.

Jos nämä vaiheet epäonnistuvat, kannattaa tutustua plugin -sivuun ja äänestää plugin, joka on rikki yhteensopivuusosion alla.

Toivomme, että tämä artikkeli auttoi vastaamaan kysymyksiisi siitä, asennatko lisäosia, joita ei testattu WordPress-versiossasi.

Jos pidit tästä artikkelista, ole hyvä ja tilaa YouTube Channel for WordPress -videotiedustosi. Löydät meidät myös Twitterissä ja Google+ -palvelussa.

Katso video: WordPressin asentaminen – Kotisivut tai blogi nopeasti ja edullisesti

Like this post? Please share to your friends:

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: